Telephone: 0333 344 7140

Victron Phoenix Inverter 12/1200 Not Working

Mike Asks:

Hi There, I have a Victron Phoenix 12/1200 Inverter. I have it wired up in my stables which are 500M from the main house. The system was working perfectly well for over a year until two days ago the victron phoenix inverter stopped working. There is no lights coming on at all.

Thanks, Mike.

Solar Ron Says:

Hi Mike, 
Most of the time when an inverter does not show any lights at all, this normally means a fuse has blown somewhere in the system. This could either be a fuse you have installed between the inverter and the battery or it could also be the internal fuse in the inverter itself. 

To check fuses you will need a multi meter with a continuity checking setting. First of all, safety first. Disconnect the battery from the system. Locate any fuses external of the inverter, remove the fuse and check it by holding the probes of the multi meter the meter should beep or perhaps show a reading of zero if the fuse is working fine. Otherwise the fuse has blown and needs replaced. Its always good practice to check the rest of the system to see if their was a reason the fuse blew in the first place.  

If the fuse is working then it could be the fuse inside the inverter. To check this you will need to open the inverter up. You would then repeat the test you just done. The image opposite shows how to remove the cover of your model of inverter, the fuse is illustrated in purple. 

I hope this helps and if you have any further issues just leave a comment below or contact us again.

Solar Ron.
Victron Phoenix 12/1200 InverterReplace Fuse of Victron Phoenix 12/1200 Inverter

Did you find this post useful?

Please consider supporting Solar Ron for all his hard work by sharing this post on your social media accounts.

Leave a Reply

Your email address will not be published. Required fields are marked *

linkedin facebook pinterest youtube rss twitter instagram facebook-blank rss-blank linkedin-blank pinterest youtube twitter instagram